Select Page

GIS/Analysis

Take advantage of the unique ability to store all of your GIS data within eRAMS.

Geographic Data

All of the geographic data you work with in eRAMS can be viewed both on the map (also called the “GIS/Analyis” section of the eRAMS platform), as well as within the “Geographic Data” tab from the Home screen. The simplest way to get started is to take a look at the data that already exists for your current projects. To do this, you’ll need to access the “Geographic Data” tab.

Open the Geographic Data Tab

Login to eRAMS. Click on the “Geographic Data” tab on the left side of the screen.

Working with Geographic Data

When the Geographic Data tab has opened, you’ll see a “Projects” folder below the “My Geographic Data” toolbar. Click on “Projects.” A list of all of your Geographic data for each project will appear under the toolbar. Select a project.

A list of placemarks, as well as all of your GIS layers associated with the project will appear.

View placemarks that you’ve created in the selected project by clicking on the “Placemarks” row.

Working with GIS Mapping and Analysis

The “GIS/Analysis” feature of eRAMS can be accessed through the “GIS/Analysis” link at the very top of every page within eRAMS. It provides many geospatial tools that can be used to perform various geospatial analytics and running eRAMS models.

Open “GIS/Analysis” for Mapping and Geospatial Analysis

Click on the “GIS/Analysis” link to go to the active project map. You’ll see a map appear with a toolbar above and one or more tabs to the left.

On the left side of the screen, the Map tab along with several other project-related tool tabs will appear. Navigation and instructions for project tool functionality are available within these project-specific tabs.

Working with the Map Tab

Below are some tips to help you get familiar with the eRAMS “Map” tab on the left side of the “GIS/Analysis” page.

The Settings Panel

Click on the “Settings” accordion panel to set distance and area units, as well as scale. The distance and area setting apply to the active Project. They are not global settings across projects and are relevant when using GIS measurement tools.

The scale setting causes the map to zoom to the scale chosen. The scale of the map will remain until a different scale setting is chosen or changed by other zoom tools on the map. The system retains the scale of the project map upon exit from the project and/or eRAMS, and resumes scale upon return to the project.

The Base Layers Panel

Click Base Layers to expand pane, displaying list of layers providing backdrop for performing location-based analysis. Click on the radio button to display the layer of choice. Base layers from Google, Bing, and USGS are available.

There are no right/left click menu options for the selected base layer. Selecting a base layer simply provides the background imagery for the project.

The Public Layers Panel

Click Public Layers to expand the Public Layers panel, displaying the list of layers for overlaying the selected base layer. Layers not enabled at the current map scale are crossed out until the user zooms to the appropriate scale range.

For many public layers, left-click on the layer name to display a choice list of options, including setting and viewing data about the feature on which the cursor is positioned. Other options include zoom, setting feature transparency and resolution, viewing general metadata about the layer, and extracting a subset of the layer to a folder in Project Layers. These options are described in more detail later in this Help.

Available public layers include:

  1. US Census 2010 – population and other demographics by state, county, tract, block group, and block.
  2. US Geodata – several USGS National Map layers available for hydrography (NHD), transportation, geographic names, government boundaries, and facilities. Further information about these layers can be found at http://nationalmap.gov.
  3. US EPA Water – layers available for water monitoring sites (STORET), permit locations (NPDES), surface and groundwater source frequency by state or hydrologic unit (SDWIS), and beaches (BEACON). Further information about these layers can be found at:

Land Use Land Cover – (1) Land use from USDA National Agricultural Statistics Service (NASS) CropScape by year, and (2) land cover from the USGS NLCD for selected years. Further information about these layers can be found at:

The User Layers Panel

Click on the User Layers panel to display list of spatial layers and tables the user has added. These layers are available to all of the user’s projects, so care should be taken to keep the list of layers from being too long and cumbersome. Project specific layers can be added under Project Layers discussed in the next section.

Right- or left-click on Spatial Layers to create or delete a Folder. Folders should be created to organize layers according to user need. Delete will remove the folder and all of its contents, including associated tables.

Right- or left-click on Spatial Layer or child folder for menu and left-click on Add option to add an external spatial layer of a selected format: shapefile or web mapping service (WMS). eRAMS expects users to be familiar with the process of adding shapefile and WMS layers from external sources.

Right- or left-click on Spatial Layer or child folder for menu and left-click on Create Layer to name the layer, specify point, line, or polygon type, and then draw layer features.

Left-click on a layer legend to open pane to edit layer properties including zoom max/min setting, symbology, and labels. Right- or left-click on the highlighted spatial layer and left click on the Properties option also opens the edit pane.

Right- or left-click on a spatial layer to display option list for turning labels on/off, deleting the layer, renaming the layer, opening associated attribute table, joining other tables to the attribute table, viewing/editing layer metadata, downloading the layer, adding to placemarks, and viewing/editing layer properties. These actions are described in more detail below.

Right- or left-click on Tables or child folder for menu and left click on Add to add a table from a local folder.

Right- or left-click on a table to display option list for renaming and deleting the table, opening the attribute table, downloading the table and associate spatial layer, adding the table to the map, and joining data to the table. These options are described in more detail below.

Project Layers Panel

Unique project related navigation and function of the spatial layers and tables in this map category are covered in project specific Help.

The basic menu options described above for User Layers and in more detail in the applicable section below apply to Project Layers as well.

Spatial layers and tables added as Project Layers are visible and available only in the active project, unless they are also added to another project. While creating a project in Home context, the user has the option of including layers from other projects.

Placemarks Panel

The placemarks created by the user using Pin tool in the GIS toolbar are listed here. Placemarks created as a menu option from right/left click on a spatial layer are listed here as well.

Left-click on the placemark in the list opens a call-out box on the map pointing to the feature (point, line, or polygon) and displays the description, location, elevation, and lat/long coordinates.

Right/Left-Click Menu Options for Highlighted Layer

Add to Placemarks – Left-click on option to establish selected feature as a placemark.

Add Table to Map – Available when right/left click on a highlighted table, left click on option to open pane for adding the table as a map layer. The table must contain x and y coordinates.

Download Layer – Left click on option to download the spatial layer and associated files to a local download folder. Download occurs without user intervention.

Download Folder – Left click on option to download highlighted spatial layer or table folder and its contents.

Export to Polygon Layer – Left click on option for a highlighted raster layer to initiate process to export to a vector polygon layer.

Extract Layer – Available for Public Layers, left click on option to open pane to extract data from the highlighted spatial layer. Select project folder or create new project folder to store extracted data. Set the geospatial extent for which data will be extracted. Click Generate to extract the data to the project folder. System will display message verifying extraction was successful.

Identify Features – Left click on option then run cursor over (or click) feature of highlighted (selected) layer to display information about the feature.

Join Data – Left click this option to append data to the attribute table of the selected layer from another table or the attribute table of another layer. All joins will be permanent.

Join Data – Left click this option to append data to the attribute table of the selected layer from another table or the attribute table of another layer. All joins will be permanent.

Map Service Metadata – Left click to display metadata provided for the selected spatial layer provided through a map service.

Metadata – Left click on option opens metadata pane for the highlighted spatial layer. Enter description, citation, keywords, and comments, then save and exit. As applicable exercise option to export metadata to a local file.

Open Attribute Table – Left click on option opens attribute table associated with the spatial layer. The opened table contains several options for acting on table contents, including edit, new column, query, create layer from selection, metadata, and export. These and other options are described in more detail in a section below.

Properties – Left click on option opens three-tab pane for editing properties of the spatial layer including scale and extent constraints, feature opacity, symbol and label characteristics.

Rename Layer – Left click on option to highlight layer or table name in edit mode. Edit name and click and click outside to close.

Select Attribute to Visualize – Available for census data in Public Layers, click on option to select attribute to view its values across layer features.

Selection – Highlighting a row in a spatial layer’s attribute table enables access to left click selection options to zoom to the selected feature, export the selected feature to a local file, or clear the selection.

Transparency/DPI – Left click on option to modify the feature transparency setting for the highlighted (selected) spatial layer. Some web mapping services provide for modifying DPI (dots per inch) setting.

Turn Labels On/Off – Self-explanatory, labels for the map features of the highlighted spatial layer can be turned off and on.

Zoom to Layer – Left click to zoom to the extent of the highlighted layer.

Zoom to Visible Extent – Left click to zoom within the scale range for the highlighted layer.

Right/Left Click Menu Options for Highlighted Spatial Layers or Tables Folder

These options are available for User Layers and Project Layers.

Add – Highlighting Spatial Layer or child folder, click on option to add a shapefile from a local folder or a layer from a web mapping service (WMS). A shapefile is a set of files, and users are expected to add the entire set provided (.shp, .dbf, .shx, .sbn, .sbx, and .prj). Enter the URL to connect to a web mapping service and select layer(s) to upload.

Highlighting Tables or child folder, click on option to add a file (.dbf, .xsl, .xslx, or .csv) from a local folder.

Create Layer – Left click on option to create a new point, line, or polygon layer. Name the layer, click OK, then go to the GIS tool bar and Digitize/Edit to create layer features on the map.

Close All – Left click on option to uncheck all spatial layers and tables, turning off display of all layer features.

Open All – Left click on option to check all spatial layers and tables, displaying their features on the map.

Download Folder – Left click on option to download highlighted folder (and contents) to a local download folder.

Rename – Left click on option to modify the spatial layer or table folder name.

Create Folder – Left click on option to create a child folder under Spatial Layers or Tables. Highlight folder and left click on option to create a child subfolder.

Delete Folder – Highlight folder and left click option to delete the folder and its contents. User is alerted to impact of this action.